The database operations are running a bit slower than expected, but they are progressing.
Posted Oct 19, 2025 - 21:41 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 19, 2025 - 19:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 19, 2025 - 11:36 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 19, 2025 - 11:35 CEST
Scheduled
Kattis will perform maintenance on the database. We expect degraded service during the maintenance window, including periods of paused judging and failures to load pages.
Posted Oct 19, 2025 - 11:21 CEST
This scheduled maintenance affected: Kattis Education (Web) and Kattis Recruiting (Web).