Kattis infrastructure is down

Incident Report for Kattis

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 20:56 CET

Monitoring

We are restoring services, and verifying that everything is working as intended.
Posted Mar 10, 2026 - 19:30 CET

Identified

We have identified the issue, and we are in the process of restoring services.
Posted Mar 10, 2026 - 19:26 CET

Update

We are in the process of debugging the issue.
Posted Mar 10, 2026 - 18:31 CET

Update

We have staff on site now, and are debugging the issue. Next update in an hour.
Posted Mar 10, 2026 - 17:52 CET

Update

We are currently moving staff on site to continue troubleshooting the issue. We expect the next update in an hour.
Posted Mar 10, 2026 - 16:42 CET

Update

We are in contact with our service provider and trying to locate the failure. It seems to be BGP related. We expect the next update in an hour.
Posted Mar 10, 2026 - 15:40 CET

Investigating

We are investigating why Kattis is down. The infrastructure is not responding, and this seems to be a networking problem.
Posted Mar 10, 2026 - 14:03 CET
This incident affected: Kattis Education (Web) and Kattis Recruiting (Web).